Главная » Вебмастеру » Плагин Classic Editor будет поддерживаться до 2021 года

Плагин Classic Editor будет поддерживаться до 2021 года

Плагин Classic Editor будет поддерживаться до 2021 года

Гэри Пендергаст объявил на днях, что плагин Classic Editor будет официально поддерживаться до 31 декабря 2021 года. Плагин позволяет облегчить переход к Gutenberg для тем и плагинов, которые пока еще не совместимы с этим редактором. Пользователи получат время на то, чтобы скорректировать свои рабочие процессы.

«Поскольку плагин Classic Editor является центральным в данном переходе, мы рассматриваем возможность включения его в обновление WordPress 5.0», — отметил Гэри. – «Однако в новых установках WordPress его нужно будет добавлять вручную. Мы внесем его в список популярных плагинов, чтобы увеличить его видимость».

Гэри пояснил, что фраза «официально поддерживается» означает, что плагин «будет работать в последнем главном релизе WordPress и в одном главном релизе перед ним». Он также отметил, что в 2021 году поддержка плагина будет повторно изучена и продлена при необходимости.

Пост уже набрал достаточно много отзывов, и в основном это положительная реакция от пользователей.

Разработчик ядра WordPress Паскаль Биршле попросил разъяснить, что означает «мы» в исходном посте, и Гэри отметил, что он выступает от лица всего проекта WordPress. Другие комментаторы запросили подробности, поскольку в исходном посте это подавалось так, словно это что-то уже решенное, хотя диалог по поводу такого решения не был публичным.

«Я благодарен за то, что у нас теперь есть четкая дата по поводу поддержки классического редактора», — отметил Даррен Этье. – «Это позволит многим пользователям, зависящим от WordPress, иметь средства к существованию. Однако для волонтеров, которые посещают мероприятия и встречи, процесс принятия решений такого рода очень непрозрачен».

Анонс подчеркивает наметившуюся тенденцию по принятию важных решений «за закрытыми дверями», без участия сообщества. Предложение Мэтью Макферсона о проведении независимого аудита доступности, которое получило широкую поддержку со стороны сообщества, было прикрыто аналогичным образом. Мэтью был назначен ответственным за доступность WordPress 5.0, но, как кажется со стороны, его не наделили достаточными полномочиями для решения этого аспекта в интересах сообщества. Я узнал у Макферсона, может ли он уточнить, почему разработчики приняли решение отказаться от аудита. Он ответил, что никаких подробностей он дать не может.

WPCampus в данный момент проводят аудит доступности, чтобы лучше управлять своим сообществом, состоящим из 800+ веб-профессионалов, преподавателей и других участников, работающих с WordPress.

«Есть высокий интерес к нам, и я постоянно провожу встречи с потенциальными клиентами, отвечаю на их вопросы», — отметила директор WPCampus Рейчел Черри. – «Мы получили кучу сообщений от частных лиц и организаций, которые хотели помочь нам материально».

Недавний отчет от команды доступности продемонстрировал наличие серьезных проблем в Gutenberg, что мешает рекомендовать этот редактор пользователям ассистивных технологий. Проблемы оказывают значительное влияние на тех, кто использует WordPress в образовательных целях, поскольку законодательство требует соблюдения определенных стандартов. По этой причине многие ратовали за поставку плагина Classic Editor для новых установок WordPress.

«Многие организации, использующие WordPress, по закону обязаны предоставлять доступное программное обеспечение в соответствии с Section 508», — рассказала Рейчел. – «До тех пор, пока доступность Gutenberg не будет улучшена, этим организациям придется требовать от пользователей установки Classic Editor».

«Соответственно, пользователи будут зависеть от Classic Editor, чтобы иметь доступный процесс публикации материалов»

«Пожалуйста, подумайте о том, чтобы поставлять Classic Editor со всеми версиями ядра, новыми и обновленными. Каждый пользователь должен иметь простой и всеобъемлющий вариант для использования с первого дня работы с WP».

Элейн Шэннон, пользователь WP, работающий в академических кругах, также прокомментировал пост Гэри, порекомендовав внести Classic Editor во все новые версии WordPress:

«Некоторые учреждения сидят на администрируемых хостингах. В результате этого они получат WordPress 5.0 без инициации обновления», — отметила Элейн. – «В других учреждениях имеются свои IT-отделы в кампусах. Администраторы кампуса могут запросто обновить WordPress, что затронет тысячи пользователей. В большинстве случаев это мультисайты, где пользователи лишены выбора. У них нет возможности установки плагинов. Если же Classic Editor не будет поставляться вместе с ядром, то в таком случае пользователям придется связываться с администраторами, чтобы откатиться к классическому редактору».

В посте Гэри было отмечено, что разработчики WP рассматривают возможность включения плагина в релиз 5.0, однако неясно, где и когда это решение будет принято. Пользователи, зависящие от классического редактора, при этом узнали приятную для себя новость – плагин будет поддерживаться вплоть до 2021 года.

«Что касается сроков поддержки классического редактора — я очень рад, что у нас появилась фиксированная дата», — рассказал разработчик WordPress Дрю Джейнс. – «Мы имеем хороший сигнал, что плагин – не долгосрочное решение, а временная мера для переходного периода к Gutenberg».
Источник

Интересные публикации по этой теме: