Главная » Вебмастеру » Gutenberg 5.0: новый RSS-блок, блок Amazon Kindle, а также новый компонент FocalPointPicker

Gutenberg 5.0: новый RSS-блок, блок Amazon Kindle, а также новый компонент FocalPointPicker

Gutenberg 5.0: новый RSS-блок, блок Amazon Kindle, а также новый компонент FocalPointPicker

Недавно вышла новая версия плагина Gutenberg 5.0, в которой появился блок RSS. Риад Бенгуэлла, технический руководитель фазы 2 Gutenberg, опубликовал демо-видео этого блока и его настроек. Пользователи могут задавать количество отображаемых пунктов, включать/отключать имя автора, дату, цитату.

Gutenberg 5.0: новый RSS-блок, блок Amazon Kindle, а также новый компонент FocalPointPicker

Формат RSS сегодня все еще актуален. Это один из стержней открытой сети. Gutenberg позволяет легко размещать фид внутри поста или страницы. Раньше эта функция была ограничена только виджетизированными областями. Добавление этого блока отражает перенос всех существующих виджетов ядра WordPress в блоки.

Версия 5.0 также добавляет новый блок Amazon Kindle, который обеспечивает мгновенные превью с Amazon Kindle. В WordPress уже была реализована ранее oembed-поддержка Amazon Kindle URL, но этот элемент отсутствовал в секции Embeds инструмента вставки блоков.

Наиболее интересное дополнение в данном релизе – новый FocalPointPicker для блока Cover. Он позволяет пользователям выбирать идеальную центральную точку изображения и возвращает ее в виде пары координат, которые затем конвертируются в атрибуты background-position. В результате пользователь может лучше контролировать обрезку изображения. Эта функция решает много проблем, с которыми сталкиваются пользователи при обрезке и выводе изображений в темах WordPress.

FocalPointPicker – реюзабельный компонент, т.е. разработчики могут использовать его для создания других блоков с такими же возможностями, обеспечивая качественный и непротиворечивый опыт взаимодействия.

Gutenberg 5.0: новый RSS-блок, блок Amazon Kindle, а также новый компонент FocalPointPicker

Изменения, появившиеся в Gutenberg 5.0, доступны для тех, кто работает с плагином на своих сайтах (только для WordPress 5.0+). Обновления в Gutenberg 5.0 должны войти в WordPress 5.2.
Источник

Интересные публикации по этой теме: